Print at Nov 13, 2018 12:10:05 AM

Posted by salimkamal at Jun 23, 2016 11:33:48 PM
Re: How to get Sweet Home 3D working on Ubuntu 16.04 LTS?
I am using linux for the past 10 years mainly ubuntu or one of its derivatives. I had the same problem with Xubuntu 16.04. I am using the SweetHome3D 5.2.tgz downloaded from Sweethome 3D website and uncompress it in a local folder. after running the executable file named “SweetHome3D” in a terminal (double clicking doesn't execute it) the application crashes and I get this message
Java 3D: implicit antialiasing enabled
#
# A fatal error has been detected by the Java Runtime Environment:
#
# SIGSEGV (0xb) at pc=0x00007f5e3a996b6d, pid=5813, tid=140042699675392
#
# JRE version: 6.0_45-b06
# Java VM: Java HotSpot(TM) 64-Bit Server VM (20.45-b01 mixed mode linux-amd64 compressed oops)
# Problematic frame:
# C [r600_dri.so+0x1f4b6d] __driDriverGetExtensions_virtio_gpu+0x1590bd
#
# An error report file with more information is saved as:
# /media/lino/Shehata/Soft/Design and multimedia/SweetHome3D-5.2/hs_err_pid5813.log
#
# If you would like to submit a bug report, please visit:
# http://java.sun.com/webapps/bugreport/crash.jsp
#
Aborted (core dumped)

Initially I thought the problem could be a result of the open source radeon driver as ubuntu 16.04 doesn’t support the proprietary ATI driver (FGLRX), therefore I installed Xubuntu 14.04 and running the application was successful but when I tried to go to the preferences from the “File Menu” the application crashes again (I need to change the measure units from feets to meters). The same problem happened on openSuse leap 41 and Debian Jessie. Finally I installed Fedora 24 but again I was not able to change the preferences on the regular Gnome session but when I ran the SH3D in “Gnome on Wayland” session and the SH3D worked without troubles (I was able to change the preferences).

I am not a programmer, just a linux user but I think there is problem with the Xorg display server on the new linux distributions.