Print at Jan 22, 2021, 1:46:59 PM View all posts in this thread on one page
Posted by Xiste at Jul 28, 2020, 6:10:17 PM
Important if you want to go back to an older version from v 6.4
If you download and use v 6.4 and save your project, you will not be able to use any plugins if you go back to f.i. v 6.3.
Opening a v 6.4 project with version 6.3, removes the access to all your installed tools, so your project becomes useless.

Solution:
Save the project again with v 6.3, and everything works as normal.


Xiste

Posted by Puybaret at Jul 28, 2020, 9:19:52 PM
Re: Important if you want to go back to an older version from v 6.4
Øistein, I'm not sure to understand what you mean. Plug-ins compatible with Sweet Home 3D 6.3 should be still compatible with Sweet Home 3D 6.4, and the changes made in SH3D 6.4 files are actually compatible with SH3D 6.3 files, unless you really care about the IDs which were added to objects for the JavaScript version.
If a plug-in doesn't work as expected, please give more details how to reproduce your issue.
----------------------------------------
Emmanuel Puybaret, Sweet Home 3D developer

Posted by bdfd at Jul 29, 2020, 8:26:01 AM
Re: Important if you want to go back to an older version from v 6.4
Hi,

I've downloaded and installed 6.4 yesterday.

All installed plugins work fine. wink
.
----------------------------------------
SH3D 6.4.2 and nothing else - W10 64b
Asus TUF Z390 , Intel Core i9-9900KF (4.0 GHz) , Chipset Z390 Exp, RAM 32 Go DDR4 3 Ghz, SSD M.2 512 Go + HDD 3 To,
MSI GeForce RTX 2080 8Go

Posted by Xiste at Jul 29, 2020, 10:25:19 AM
Re: Important if you want to go back to an older version from v 6.4
I created a file at my office using v6.4:





Later, at home, I opened it with v6.3.





As you can see, "Tools" and "Photo-Video Rendering" is stripped from the menu bar.

In case someone else has this issue and starts to panic, I offered a solution.

Xiste

Posted by Xiste at Jul 29, 2020, 10:34:24 AM
Re: Important if you want to go back to an older version from v 6.4
The reason I prefer v 6.3, is that 6.4 will crash after 20 - 50 minutes, as v 6.3 will work for five - six hours until it has used all my memory, and shuts down.

How can I edit a post?

Posted by Puybaret at Jul 30, 2020, 8:14:46 AM
Re: Important if you want to go back to an older version from v 6.4
Actually, the missing plug-ins list is a bug that will be fixed in a future version. Thanks for reporting it.
About the stability of Sweet Home 3D 6.4, I wonder if you didn't forget to update the max memory used in this new version.
----------------------------------------
Emmanuel Puybaret, Sweet Home 3D developer

Posted by Xiste at Jul 30, 2020, 9:34:13 PM
Re: Important if you want to go back to an older version from v 6.4
I wonder if you didn't forget to update the max memory used in this new version.
No, I gave it 32 GB just like with v 6.3.

Most of my files are quite big, 1- 1.5 GB.
When opening a 1 GB project, I can see an increase in memory usage of about 12 GB, a figure that is increasing every time I add some objects or make a rendering.
When the the memory load reaches about 58 GB (on the 64 GB machines), the program is shutting down.

I'm constantly monitoring my memory load, and I have made a routine of saving and quitting when the memory load is approaching 55 GB. It normally takes about 5 hours to reach 55 GB memory usage with v 6.3.
With v 6.4, the 55 GB memory load can ( worst case) be reached within half an hour.


Most of my computers are 12 core/ 24 threads MacPro 1.5, running OSX 10,13,6 (17G14019)
They have 64 or 128 GB memory and NVIDIA GeForce GTX TITAN X 1228 MB.
They can not be upgraded above OSX 10.13.6.

Xiste