Print at Dec 16, 2018 6:10:19 PM View all posts in this thread on one page
Posted by Lumaja at Jan 28, 2015 1:47:40 PM
FurnitureLibraryEditor error
Ubuntu 12.04
Sweet Home 3D ver. 4.5

Double click on “FurnitureLibraryEditor-1.14.jar” shows error:

FurnitureLibraryEditor-1.14.jar' is not marked as executable. If this was downloaded or copied from an untrusted source, it may be dangerous to run. For more details, read about the executable bit.
What should I do now?

Posted by okh at Jan 28, 2015 2:52:28 PM
Re: FurnitureLibraryEditor error
FurnitureLibraryEditor-1.14.jar' is not marked as executable. If this was downloaded or copied from an untrusted source, it may be dangerous to run. For more details, read about the executable bit.
What should I do now?
Assuming you get the file from the download page, make sure you have Java installed and adjust Java settings to allow the library editor to run. See also thread 4794 and there are other discussions on various Java releases for Ubuntu in the forum. ok

Posted by Lumaja at Jan 30, 2015 7:44:51 AM
Re: FurnitureLibraryEditor error
I have Java installed and SH is working I think it is Java 7.
About adjust Java settings don't know how to do that,
I changed the .jar into .zip but I think is not much of use.
Went to properties Open with Open JDK Java 6 Runtime but the same error come up.

Posted by slimpy at Jan 30, 2015 1:31:23 PM
Re: FurnitureLibraryEditor error
This is probably a permission issue in Ubuntu.
Try to change the executable bit for FurnitureLibraryEditor-1.14.jar:
chmod +x FurnitureLibraryEditor-1.14.jar


Best,
slimpy

Posted by Lumaja at Jan 30, 2015 2:37:10 PM
Re: FurnitureLibraryEditor error
Thank you for your response.
Terminal result:
luis@luis-G41M-Combo:~$ chmod +x FurnitureLibraryEditor-1.14.jar
chmod: cannot access `FurnitureLibraryEditor-1.14.jar': No such file or directory
luis@luis-G41M-Combo:~$

The file is in “Home, Sweet Home 3D ver. 4.5
How I use this on command?

Posted by slimpy at Jan 30, 2015 3:17:29 PM
Re: FurnitureLibraryEditor error
Switch to the directory first using the cd command:
cd <path_to_directory>


You can also change the file permissions in the properties dialog in your file manager (Dolphin, Konqueror, etc.).

Best, slimpy

Posted by hansmex at Jan 30, 2015 4:49:55 PM
Re: FurnitureLibraryEditor error
Easiest way to change Permissions in Ubuntu is:
- select file
- right-click and select Properties
- choose tab Permissions
- put a check in the box that says "Allow to run as program" (or something similar)
- close the window.

Now the file can be run as a program.

H

Posted by Lumaja at Feb 1, 2015 6:02:07 AM
Re: FurnitureLibraryEditor error
Thank you it worked