Features

Download

Online

Gallery

Blog

  Index  | Recent Threads  | List Attachments  | Help  | Search
 Welcome Guest  |  Register  |  Login
Login Name  Password
 

Sweet Home 3D Forum



No member browsing this thread
Thread Status: Active
Total posts in this thread: 4
[ Jump to Last Post ]
Post new Thread
Author
Previous Thread This topic has been viewed 4867 times and has 3 replies Next Thread
shimitar
Newbie



Italy
Joined: Oct 12, 2016
Post Count: 2
Status: Offline
Reply to this Post  Reply with Quote 
Issue with Java or what?

System: Linux, Gentoo, on 64bit. Java oracle-jdk-bin-1.8.

If i start the lastest SH3D with the bundled VM i get most of the menus and the help messages blank... but it works.

If i start it with the system VM, i get all the strings, menus and help dialogs properly, but loading some model i have the screen remains gray, and i need to move the mouse over all the toolbar buttons or menus, for example, to get them back visibile. The 3D view is gray but i can get it to show if i am lucky enugh to hit the small arrows buttons (or select show in separate view from the menu, whatever make it redraw). The plan view, instead, i cannot find any way to get it repaint and show.

I tried to download and run JRE 7 from Oracle as well, it behaves like the system VM.

Does nybody have any hints?

I am on an Asus Zenbook laptop with Sandy Bridge chipset. OpenGL works well on many games, have no issues whatsowever with video or 3D. I am kernel 4.8.1 and latest intel video drivers.
[Oct 12, 2016 7:14:28 AM] Show Printable Version of Post    View Member Profile    Send Private Message [Link] Report threatening or abusive post: please login first  Go to top 
Puybaret
Expert
Member's Avatar

France
Joined: Nov 7, 2005
Post Count: 5837
Status: Offline
Reply to this Post  Reply with Quote 
Re: Issue with Java or what?

Could you try the version 5.3 beta 7 version available here?
----------------------------------------
Emmanuel Puybaret, Sweet Home 3D developer
[Oct 20, 2016 11:56:49 AM] Show Printable Version of Post    View Member Profile    Send Private Message    Hidden to Guest    http://www.eteks.com [Link] Report threatening or abusive post: please login first  Go to top 
shimitar
Newbie



Italy
Joined: Oct 12, 2016
Post Count: 2
Status: Offline
Reply to this Post  Reply with Quote 
Re: Issue with Java or what?

Just tried your new beta! It works much better!
It is still quite slow, but all the issues have disappeared! Beside overall GUI speed (lags a log, specially when selecting / dragging / rotating things) now all the drawing issues have been solved!

Great work!
[Oct 20, 2016 9:40:10 PM] Show Printable Version of Post    View Member Profile    Send Private Message [Link] Report threatening or abusive post: please login first  Go to top 
Puybaret
Expert
Member's Avatar

France
Joined: Nov 7, 2005
Post Count: 5837
Status: Offline
Reply to this Post  Reply with Quote 
Re: Issue with Java or what?

Thanks for your feedback smile
----------------------------------------
Emmanuel Puybaret, Sweet Home 3D developer
[Oct 21, 2016 8:24:27 AM] Show Printable Version of Post    View Member Profile    Send Private Message    Hidden to Guest    http://www.eteks.com [Link] Report threatening or abusive post: please login first  Go to top 
[ Jump to Last Post ]
Show Printable Version of Thread  Post new Thread

    Get Sweet Home 3D at SourceForge.net. Fast, secure and Free Open Source software downloads
   
© Copyright 2006-2017 eTeks - All rights reserved