Features

Download

Online

Gallery

Blog

  Index  | Recent Threads  | List Attachments  | Help  | Search
 Welcome Guest  |  Register  |  Login
Login Name  Password
 

Sweet Home 3D Forum



No member browsing this thread
Thread Status: Active
Total posts in this thread: 2
[ Jump to Last Post ]
Post new Thread
Author
Previous Thread This topic has been viewed 2585 times and has 1 reply Next Thread
dgbutterworth
Newbie




Joined: Mar 20, 2016
Post Count: 3
Status: Offline
Reply to this Post  Reply with Quote 
No icon, missing textures, general installation questions

Hi, and many thanks for a great program.
I'd love some help cleaning up my installation.
Context/History:
- System: Mint 17.3
- Installation: Long ago, I install SH3D with the system package manager. It worked great, but was sadly out of date. In the process of upgrading, I got the Java Web Start to work, but could not get things to work in the ordinary manner.
- Version 5.3 - A great development. I got it to work on my system. Not being very sophisticated with Linux, I simply unpacked the program in the download folder (/home/dgb/Downloads-link/sweethome3d/SweetHome3D-5.3/) and spun it up. The primary script failed - pop-uo error message:

3D Error
Sweet Home 3D will exit now because of a fatal error in the 3D rendering system of you [sic] computer. Please update the DirectX/OpenGL drivers of your computer graphics card.

No problem - I fell back to "SweetHome3D-Java3D-1_5_2" => BINGO! I placed a link to my install on the desktop: "/home/dgb/Downloads-link/sweethome3d/SweetHome3D-5.3/SweetHome3D-Java3D-1_5_2" and lived happily.
- Version 5.4 - with things looking stable, I followed the directions for installation found at: https://howto-ubuntunew.blogspot.fr/2016/11/h...-sweet-home-3d-53-in.html .
Thus, my current functional install is at: /opt/SweetHome3D-5.4/
Running SweetHome3D script - I get the same 3D error that I got with version 5.3. No problem - SweetHome3D-Java3D-1_5_2 works just fine - with desktop link thereto.
Per the directions from HowToUbuntuNew - I attempted to create a launcher. I tweaked the instructions hoping to aim for the alternative launcher, as follows:
created file at:
/usr/share/applications/sweethome3d-5.4.desktop


file text:

[Desktop Entry]
Version=1.0
Name=Sweet Home 3D 5.4
GenericName=Interior 2D design application with 3D preview
GenericName[de]=Innenraumplaner
Comment=Interior design Java application for quickly choosing and placing furniture on a house 2D plan drawn by the end-user with a 3D preview
Exec=/opt/SweetHome3D-5.4/SweetHome3D-Java3D-1_5_2
Icon=sweethome3d
StartupNotify=true
StartupWMClass=com-eteks-sweethome3d-SweetHome3D
Terminal=false
Type=Application
Categories=Graphics;2DGraphics;3DGraphics;
Keywords=interior;design;2D;3D;home;house;furniture;java;

The launcher was created and appears in my menu, but when clicked, I get the 3D Error noted above (so it appears to be aimed at the standard launcher, not the 1_5_2 launcher that works for me)
Also, while I attempted to update the app logo, as directed:
grab a logo icon from web. Name it sweethome3d.png and put it under /usr/share/icons/. or copy sweethome3d.png in folder SweetHome3D-5.3 put it under /usr/share/icons/.

Now the launcher has no logo, and when I run the script that works the app has no icon on the system panel.

Finally, I have for a while tried to import the available textures. Most recently, I imported Textures-Contributions-1.2.zip
I see very few textures available in the program.
I note that the extensions and furniture library all work fine, and are visible from the "about" window. But the Libaries window lists only "furniture" and "extensions". It seems that it should list textures also, but it does not.

Things are working well enough, but it would be great to clean things up, and get them to work better.

Any help would be appreciated. Thanks.
David

dgbutterworth
"... if it ain't broke, try harder"
[Feb 7, 2017 8:42:08 PM] Show Printable Version of Post    View Member Profile    Send Private Message [Link] Report threatening or abusive post: please login first  Go to top 
Puybaret
Expert
Member's Avatar

France
Joined: Nov 7, 2005
Post Count: 5837
Status: Offline
Reply to this Post  Reply with Quote 
Re: No icon, missing textures, general installation questions

From my own attempts, the line:
Icon=sweethome3d
should be rather:
Icon=/opt/SweetHome3D-5.4/SweetHome3DIcon.png

And about textures (or furniture) libraries, don't import the zip files you downloaded but the .sh3t (or .sh3f) they contain.
----------------------------------------
Emmanuel Puybaret, Sweet Home 3D developer
[Feb 7, 2017 9:07:53 PM] Show Printable Version of Post    View Member Profile    Send Private Message    Hidden to Guest    http://www.eteks.com [Link] Report threatening or abusive post: please login first  Go to top 
[ Jump to Last Post ]
Show Printable Version of Thread  Post new Thread

    Get Sweet Home 3D at SourceForge.net. Fast, secure and Free Open Source software downloads
   
© Copyright 2006-2017 eTeks - All rights reserved