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Windows Linux Mac OS X Windows Linux Mac OS X
FILE
Open a new home File > New cmd N
Open a previously saved home File > Open... cmd O
Save the edited home File > Save cmd S
Save the edited home under an other name File > Save as... cmd shift S
Save the edited home in a compressed file with same quality File > Save and compress cmd alt S
Close the edited home File > Close cmd W
Display Page setup  pane File > Page setup... cmd shift P
Print the edited home File > Print... cmd P
Display Preferences  pane File > Preferences… 

(Sweet Home 3D > Preferences… 
under Mac OS X)

cmd , 

EDIT
Transfer the focus to a pane 
(pane surrounded by a colored rectangle receiving keyboard inputs)
Undo the last action Edit > Undo cmd Z
Redo the last undone action Edit > Redo cmd shift Z
Copy and delete the items selected in home Edit > Cut cmd X
Copy the selected items in clipboard
(+ a text of the selected furniture when the furniture list has focus
 or an image of the selected items when the plan has focus)

Edit > Copy cmd C

Paste the copied or cut items into home Edit > Paste cmd V
Paste the copied or cut piece into the group selected in home Edit > Paste to group cmd shift V
Paste the style of the copied or cut item to the selected ones
(the copied and selected items must be of the same type)

Edit > Paste style cmd alt V

Delete the selected items Edit > Delete Back space
Select all items in the furniture list or the plan Edit > Select all cmd A
FURNITURE
Select a piece in furniture catalog or furniture list
Select contiguous pieces in furniture catalog or furniture list
Sort furniture list Furniture > Sort by > Column

Toggle the selection of a piece in furniture catalog or furniture list cmd + Click
Add the piece selected in the catalog to the plan at (0,0) Furniture > Add to home cmd shift F
Add a piece of the catalog anywhere in the plan
Display the modification pane of the selected pieces of furniture Furniture > Modify... cmd E
Create a group from selected pieces Furniture > Group cmd shift G
Ungroup all the pieces of the selected groups Furniture > Ungroup cmd shift U
Align side by side selected pieces of furniture Furniture > Align side by side cmd shift B
Reset the elevation of selected pieces according to their environment Furniture > Reset elevation cmd shift Y
Display the wizard used to import a 3D model as a piece of furniture
(at second step, use Shift key to rotate degree by degree the 3D model)

Furniture > Import furniture… cmd shift I

Ctrl A

Ctrl E
Ctrl Shift G

Shift + Click on the last pieceShift Arrows ←↑↓→ 

Drag and drop piece in furniture list

Drag and drop a OBJ, 3DS, DAE, KMZ or
ZIP file onto catalog, furniture list or plan

Ctrl Shift U
Ctrl Shift B

Keyboard shortcuts

Tab or Shift + Tab

Drag and drop catalog piece in the plan

Click on the piece

Mouse actions

Ctrl N

Click in the pane

Arrows ←↑↓→

Ctrl + Click

Ctrl O

Del

Ctrl Shift F

Ctrl S
Ctrl Shift S
Ctrl Alt S
Alt F4

Ctrl X

Ctrl V

Ctrl Alt V

Ctrl Shift P
Ctrl P
Ctrl M

Ctrl Z
Ctrl Y

Ctrl Shift I

Ctrl Shift V

Ctrl Shift Y

Double-click on a piece

Action Menu item Icon 

Ctrl C

Click once on column header for 
ascending sort, twice for descending sort
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Keyboard shortcuts Mouse actionsAction Menu item Icon 

Display the wizard used to import an image as a texture
(at first step, a BMP, JPEG, GIF or PNG file can be dragged onto wizard)

Furniture > Import texture... cmd alt I

PLAN
Switch to the Select  mode Plan > Select cmd L
Select the foremost item under mouse cursor
Toggle the selection of the foremost item under mouse cursor
Select items intersecting a selection rectangle

Toggle the selection of items intersecting a selection rectangle

Select an item under mouse cursor (including hidden items)

Toggle the selection of an item under mouse cursor

Move selected items pixel by pixel
Move selected items 10 pixels by 10 pixels
Move selected items along horizontal or vertical plan axis

Duplicate selected items alt + Drag and
drop selection

Duplicate selected items along horizontal or vertical plan axis alt + shift 
+ Drag and drop

Toogle temporarily magnetism set in preferences 
while moving the selected item

Alt while 
dragging

Shift Alt while 
dragging

cmd while 
dragging

Switch to the Pan  mode Plan > Pan cmd alt P
Pan in the plan in Pan  mode
Pan in the plan in other modes
Pan up and down in the plan Mouse wheel
Pan left and right in the plan
Zoom in plan and pan to show selected items Plan > Zoom in Ctrl K Ctrl + cmd +
Zoom out Plan > Zoom out Ctrl Shift K Ctrl - cmd -
Zoom in or out centered on mouse cursor cmd + Wheel
Lock the base plan (preventing the selection of base plan items) Plan > Lock base plan cmd alt L
Unlock the base plan (when the base plan is locked) Plan > Unlock base plan cmd alt L
Force the scale line to be horizontal or vertical during the second step 
of Import backgroung image  wizard
WALL
Switch to the Create walls  mode Plan > Create walls cmd shift W
Draw a wall and subsequent walls (in Create walls  mode)
Curve currently drawn wall (in Create walls  mode) alt + Click

+ Angle + Click
Enter wall dimensions with the keyboard (in Create walls  mode)
End drawing walls (in Create walls  mode)

Drag and drop mouse 

Enter

Space + Drag and drop mouse

Right click + choose item
in Select object  submenu

Ctrl Alt I

Ctrl + Click + Choose 
angle with mouse + Click

Esc / Double Enter in keyboard mode

Drag selected items, pressing the
Shift key after the first mouse move

Drag and drop selected items

Shift + Right click + choose item
in Toggle selection  submenu

Page up ⇞ / Page down ⇟ Swipe 
trackpad

Ctrl Alt P

Press mouse button over no item 
and drag mouse over items

Ctrl L

Arrows ←↑↓→
Shift Arrows ←↑↓→ 

Press Shift while dragging scale line ends

Ctrl Alt L
Ctrl Alt L

Ctrl Shift W

Ctrl + Drag and drop
selected items
Ctrl + Shift + Drag and 
drop selected items

Ctrl + Mouse wheel 

Click at wall start then at each wall end

Double-click at last wall end

Shift + Press mouse button and drag 
mouse over items

Shift + Mouse wheel Ctrl ⇞ / ⇟

Shift + Click on item
Click on item (in Select  mode)
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Create missing walls around a room (in Create walls  mode)
Display the modification pane of the selected walls Plan > Modify walls… cmd shift E
Join the closest free ends of the selected walls Plan > Join walls cmd alt J
ROOM
Select Create rooms  mode Plan > Create rooms cmd shift R
Draw a room (in Create rooms  mode)
Enter room dimensions with the keyboard (in Create rooms  mode)
End drawing a room (in Create rooms  mode)
Create a room surrounded by walls (in Create rooms  mode)
Display the modification pane of the selected rooms Plan > Modify rooms…  cmd alt E
Add a point to an existing room

Delete a point from an existing room

POLYLINE
Switch to the Create polylines  mode Plan > Create polylines cmd shift J
Draw a polyline (in Create polylines  mode)
Curve drawn polyline (in Create polylines  mode) alt + Click at end

of first segment
Enter segment dimensions with the keyboard (in Create polylines 
End drawing a polyline (in Create polylines  mode)
Display the modification pane of the selected polylines Plan > Modify polylines... cmd alt shift E
DIMENSION
Switch to the Create dimensions  mode Plan > Create dimensions cmd shift L
Draw a dimension (in Create dimensions  mode)

Draw a dimension along a piece of furniture, a wall or a room side
(in Create dimensions  mode)
Enter dimensions with the keyboard (in Create dimensions  mode)
TEXT
Switch to the Add texts  mode Plan > Add texts cmd shift T
Enter a new text
Display the modification pane of the selected texts Plan > Modify text
Increase the text size of the selected items (texts, rooms, dimensions) Plan > Modify text style 

        > Increase size
Ctrl Alt K Ctrl Alt + cmd ctrl +

Decrease the text size of the selected items (texts, rooms, dimensions) Plan > Modify text style 
        > Decrease size

Ctrl Alt Shift K Ctrl Alt - cmd ctrl -

Toggle bold text style of the selected items (texts, rooms, dimensions) Plan > Modify text style > Bold cmd B
Toggle italic text style of the selected items (texts, rooms, dimensions) Plan > Modify text style > Italic cmd I
LEVEL
Add a level Plan > Add level cmd alt N
Add a level at the same elevation as the selected one Plan > Add level at same elevation cmd shift N
Select a level in plan

Ctrl + Click at the end 
of the first segment

Double-click on a wall

Ctrl Alt N
Ctrl Shift N

Enter

Right click on room border + select 
Add point to room  menu item
Right click on room point + select 
Delete point from room  menu item

Click on level tab

Click at each end, move mouse to resize 
extension lines and click

Double-click on a polyline

Click at text location and enter text

Double-click on a room

Enter

Esc / Double Enter in keyboard mode

Click at each corner of the room

Double-click at the last corner
Enter

Double-click inside a closed surface

Ctrl B

Arrows ← → with the focus on tabs

Ctrl Shift J

Esc / Double Enter in keyboard mode

Ctrl I

Ctrl Shift R

Ctrl Alt E

Ctrl Alt Shift E

Ctrl Alt J

Ctrl Shift T

Double-click on a text

Ctrl Shift L

Move mouse on piece, wall or room side, 
double-click, resize extension lines and 

Click at each point of the polyline

Double-click at the last point

Ctrl Shift E
Double-click in a room



 Sweet Home 3D shortcuts

    Version 7.0 © Copyright 2022 eTeks Page 4    

Windows Linux Mac OS X Windows Linux Mac OS X
Keyboard shortcuts Mouse actionsAction Menu item Icon 

Display the modification pane of the selected level Plan > Modify level... cmd alt B
Make the selected level unviewable in the plan and 3D view Plan > Make level unviewable cmd shift H
Make the selected level viewable (when the level is unviewable) Plan > Make level viewable cmd shift H
3D VIEW
Switch to Aerial view  mode 3D view > Aerial view cmd D
Switch to Virtual visit  mode 3D view > Virtual visit cmd shift D
Turn point of view around scene center in Aerial view  mode
or turn visitor head left, right, up and down in Virtual visitor  mode
Turn point of view or visitor head 5 times faster

Swipe trackpad

Shift + Swipe

Move visitor up and down in Virtual visitor  mode
Move visitor up and down 5 times faster 
Move visitor sideways in Virtual visitor  mode
Move visitor sideways 5 times faster 
Display the modification pane of the virtual visitor (in Virtual visitor 3D view > Modify virtual visitor... cmd alt M
Store the current point of view 3D view > Store point of view... cmd alt R
Display the 3D view in a separate window 3D view > Display 

                 in separate window
cmd alt Y

Display the 3D view in the main window (when it's in a separate 
window)

3D view > Display in main window cmd alt Y

Make all levels viewable in the 3D view 3D view > Display all levels cmd alt A
Make only the selected level and below viewable in the 3D view 3D view > Display selected level cmd shift A
Display the modification pane of the 3D view 3D view > Modify 3D view… cmd shift M
HELP
Display Sweet Home 3D help window Help > Sweet Home 3D help cmd ?

Shift W S or Shift Arrows ↑ ↓ Shift + Roll mouse wheel
or Shift + Alt + Vertical mouse moves 
with button pressed

Shift Alt Arrows ← →

Ctrl Shift M
Ctrl Shift A

Ctrl Alt R
Ctrl Alt Y

Ctrl Alt Y

Ctrl Alt A

Move forward/backward 5 times faster 

Ctrl Alt B

Ctrl Shift H
Ctrl Shift H

Ctrl D

Move forward/backward in Aerial view  or Virtual visitor  modes 

Move mouse with left button pressed

Home / End
Shift Home / End

A D or Arrows ← → ⇞ ⇟

W S or Arrows ↑ ↓
or Alt + Vertical moves with button pressed

Ctrl Shift D

Shift + Move mouse with button pressed
Roll mouse wheel

Double-click on level tab

F1

Ctrl Alt M

Alt Arrows ← →

Shift A D or Shift Arrows ← → ⇞ ⇟

• Under Mac OS X, a right click can also be achieved thanks to a click with ctrl key pressed
• Typing the + sign might require to also press the Shift key according to the layout of your keyboard
• Home ⤒, End ⤓, Page up ⇞, Page down ⇟ keys can be accessed with fn + arrow keys on some laptop keyboards
• Some icons cited in Icon  column are not displayed in the toolbar
Notes:


